[phpBB Debug] PHP Warning: in file [ROOT]/phpbb/session.php on line 585: sizeof(): Parameter must be an array or an object that implements Countable
[phpBB Debug] PHP Warning: in file [ROOT]/phpbb/session.php on line 641: sizeof(): Parameter must be an array or an object that implements Countable
Question about keyboard wobbly - Carers UK Forum

Question about keyboard wobbly

Socialise and chat about other areas of your life
Hi , wondered if anyone had any brainwaves on this one. My keyboard is no longer picking up the correct function above the numbers on the top row. Seems to be just one or two that have gone wrong. For example the number 2 along the top row has a symbol for quotation marks above it that you pick up using the shift key or cap lock. If I press shift or cp lock with it at the moment I am getting the @ sign. I have just tried clicking the comma which has the @ sign above it and I am getting quotation marks!.
I have run liveupdate on Norton and run a full system scan, no viruses detected.
Any Suggestions welcome :D
Hi Henrietta,

You don't say what operating system you are using. Have you restarted the computer?
It may be that you have accidentally changed the keyboard selection.
I was going to try to help you because I have Windows and Mac, but I noticed that my Windows is German so perhaps I should leave it to someone else. But there should be some language settings somewhere where you could check that the correct English keyboard is installed.
Greta wrote:Hi Henrietta,

You don't say what operating system you are using. Have you restarted the computer?
It may be that you have accidentally changed the keyboard selection.
I was going to try to help you because I have Windows and Mac, but I noticed that my Windows is German so perhaps I should leave it to someone else. But there should be some language settings somewhere where you could check that the correct English keyboard is installed.
Hi Greta
Thanks for reply- I am on windows 10 and have been for ages, also keep Norton software up to date. Where can I check for languages?
Running Chrome for browser.
I usually just let laptop sleep and keep it on but strangely enough I did turn it off last night right back to shut down mode because it seemed to be quite warm.
It sounds as though it's set up as a us keyboard rather than a uk one. Hunt through settings to see where it can be changed
Definitely need to change keyboard language settings !

Go to Control Panel > select Language > you'll probably see it set to English Language (USA) - you need to change it to English Language (United Kingdom) or English Language (United Kingdom) Extended.

Because Microsoft is an american company the default setting is the US keyboard version - when I first got Windows10 I ended up having to download the UK keyboard version !
Hi Greta and Susie
Many thanks,
I turned it off to shut down mode again last night and miraculously this morning the keys are typing correctly. I checked languages anyway and I have two listed- English USA and English UK but the American one was at the top so seemed to have become the default. I have swapped them over so now UK is at the top.
Thanks very much for sorting this
While we are on the subject :lol: I don't know how to change my spell checker to English UK. When I type in forums or use Word (a fairly recent version but sorry not sure what version but when it changed significantly) I am always having spellings highlighted to the us version which is a pain. For example when I type colour I get get a red wiggly line beneath it because it thinks it should be color. Any ideas how to amend would be most welcome.
It is still doing this even after I have done amendment as above. It always has done this .
If you're using Chrome try this link - https://support.google.com/chrome/answe ... 4?hl=en-GB
But when I get the red line under an english spelling I just click on 'add to dictionary' (in the drop down box when you right click on the "mis-spelled" word) - over time I think I've added most of the UK spellings :lol: :lol:

To change the default in Word documents -
(1)open a blank document
(2) Click on the Review tab
(3) Click on Language

you can use either 'Set proofing language' or 'language preferences' to change the default.

What does really, really bug me is that when I'm typing forum replies Chrome doesn't automatically correct lower case i to upper case I - it's OK if I use Internet Explorer and it's OK in Word documents. I've searched the internet for an answer but it seems that a lot of people have the same gripe and Chrome won't do anything to rectify it :(

(to stop the keyboard issue raising it's head again you can delete the US keyboard option)
They're separate problems I think - I don't think there is a global spellchecker, just one for word and one for your browser. Yet again all the commands are in German on my programs so try the Help in Word - there will be a page where you can disable the spellchecker or change it to UK English if you like it. At the moment I can't type in German on my phone without everything getting red wiggly lines. It drives me mad but I can't be bothered to change it. I could spend my life sorting out computer problems!
p.s. just tried the link above and it works !

when I got to the bit to change the default if showed English (United States) and just plain English - but go to the 'add' button and choose English (United Kingdom) from the drop down menu as 'English' doesn't do the trick.
Hi Susie

Thank you very much - that is brilliant- I have done all three

Colour liaise neutralising ! No red squiggly lines -ok in forum and word.
That has been niggling me for so long- huge thanks :D